import re
regex = re.compile(r"((AND|OR|NOT)( ))?([a-z_A-Z0-9]*):(\"\w+.*\"|\w+(:?\w+))", flags=re.MULTILINE)
test_str = ("homo sapiens AND curationstatus:\"Manually curated\" AND modellingapproach:\"Ordinary differential equation model\"\n\n"
"test AND UNIPROT:23456 AND metabolism AND heart AND TAXONOMY:40674 AND curation:\"Non curated\" AND GO:GO:34212 AND publication:23444 AND modellingapproach:\"logical model\" AND cancer\n\n"
"modelformat:\"SBML\" AND modelformat:\"SBML\" AND modellingapproach:\"Ordinary differential equation model\" AND TAXONOMY:9606\n\n"
"*:* AND modelformat:\"SBML\" AND modellingapproach:\"Ordinary differential equation model\" AND TAXONOMY:9606 AND TAXONOMY:10090\n\n"
"*:* AND disease:\"Lung Adenocarcinoma\" AND cancer AND tumor")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")