const regex = /<(th|td)>.*?<\/\1>(*SKIP)(*F)|\n/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(th|td)>.*?<\\\/\\1>(*SKIP)(*F)|\\n', 'gs')
const str = `<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td>cell
content</td><td>cell 2</td></tr>
</table>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);