# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<(th|td)>.*?<\/\1>(*SKIP)(*F)|\n"
test_str = ("<table>\n"
"<tr><th>HEader 1</th><th> header \n"
"2</th>\n"
"</tr>\n"
"<tr><td>cell \n"
"content</td><td>cell 2</td></tr>\n"
"</table>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.