use strict;
my $str = '<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td>cell
content</td><td>cell 2</td></tr>
</table>';
my $regex = qr/<(th|td)>.*?<\/\1>(*SKIP)(*F)|\n/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";