re = /<(th|td)>.*?<\/\1>(*SKIP)(*F)|\n/
str = '<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td>cell
content</td><td>cell 2</td></tr>
</table>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result