using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d)(\d(?!\2))(?!\3)(\d(?!\3)))\1";
string input = @"234234, 345345, 359359 but not match 211211, 355355, 454454";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}