import re
regex = re.compile(r"((\d)(\d(?!\2))(?!\3)(\d(?!\3)))\1")
test_str = "234234, 345345, 359359 but not match 211211, 355355, 454454"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")