$re = '/((\d)(\d(?!\2))(?!\3)(\d(?!\3)))\1/';
$str = '234234, 345345, 359359 but not match 211211, 355355, 454454';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);