const regex = /((\d)(\d(?!\2))(?!\3)(\d(?!\3)))\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d)(\\d(?!\\2))(?!\\3)(\\d(?!\\3)))\\1', 'g')
const str = `234234, 345345, 359359 but not match 211211, 355355, 454454`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}