import Foundation
let pattern = #"((\d)(\d(?!\2))(?!\3)(\d(?!\3)))\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"234234, 345345, 359359 but not match 211211, 355355, 454454"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)