re = /((\d)(\d(?!\2))(?!\3)(\d(?!\3)))\1/
str = '234234, 345345, 359359 but not match 211211, 355355, 454454'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end