# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\(link\)(.*?)\(\\/link\)/<a href='$1'>$1<\/a>/g;t' <<< "(link)there is link1(/link), (link)there is link2(/link)"