import Foundation
let pattern = #"\(link\)(.*?)\(\/link\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"(link)there is link1(/link), (link)there is link2(/link)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href='$1'>$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)