re = /\(link\)(.*?)\(\/link\)/
str = '(link)there is link1(/link), (link)there is link2(/link)'
subst = '<a href=\'$1\'>$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result