using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(link\)(.*?)\(\/link\)";
string substitution = @"<a href='$1'>$1</a>";
string input = @"(link)there is link1(/link), (link)there is link2(/link)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}