use strict;
my $str = '(link)there is link1(/link), (link)there is link2(/link)';
my $regex = qr/\(link\)(.*?)\(\/link\)/p;
my $subst = '<a href=\'$1\'>$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";