import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\*[\\wа-я\\'\\-\\;\\s\\r\\n\\*]*\\*\\/)|(\\/\\/[\\wа-я\\s\\'\\-\\;]*)|(\\<![\\-\\-\\sа-я\\w\\>\\/]*\\>)";
final String string = "import lodash from 'lodash';\n"
+ "window._ = lodash;\n\n"
+ "import angular from 'angular';\n"
+ "window.angular = angular;\n\n"
+ "import 'angular-ui-router';\n"
+ "import 'angular-ui-mask';\n"
+ "import 'angular-sanitize';\n"
+ "import 'angular-cookies';\n"
+ "import 'ng-dialog';\n\n"
+ "import moment from 'moment';\n"
+ "window.moment = moment;\n\n"
+ "import ff from 'angular-ff';\n"
+ "window.ff = ff;\n\n"
+ "import 'angular-ff-restful';\n"
+ "import 'angular-ff-loading';\n\n"
+ "import 'angular-ff-auth';\n"
+ "// TODO импортируем auth provider\n"
+ "//import 'angular-ff-auth-oauth';\n\n"
+ "/*\n"
+ "aaaaa-ssss;\n"
+ "*/";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}