# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\/\*[\wа-я\'\-\;\s\r\n\*]*\*\/)|(\/\/[\wа-я\s\'\-\;]*)|(\<![\-\-\sа-я\w\>\/]*\>)"
test_str = ("import lodash from 'lodash';\n"
"window._ = lodash;\n\n"
"import angular from 'angular';\n"
"window.angular = angular;\n\n"
"import 'angular-ui-router';\n"
"import 'angular-ui-mask';\n"
"import 'angular-sanitize';\n"
"import 'angular-cookies';\n"
"import 'ng-dialog';\n\n"
"import moment from 'moment';\n"
"window.moment = moment;\n\n"
"import ff from 'angular-ff';\n"
"window.ff = ff;\n\n"
"import 'angular-ff-restful';\n"
"import 'angular-ff-loading';\n\n"
"import 'angular-ff-auth';\n"
"// TODO импортируем auth provider\n"
"//import 'angular-ff-auth-oauth';\n\n"
"/*\n"
"aaaaa-ssss;\n"
"*/")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.