// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\/\*[\wа-я\'\-\;\s\r\n\*]*\*\/)|(\/\/[\wа-я\s\'\-\;]*)|(\<![\-\-\sа-я\w\>\/]*\>)").unwrap();
let string = "import lodash from 'lodash';
window._ = lodash;
import angular from 'angular';
window.angular = angular;
import 'angular-ui-router';
import 'angular-ui-mask';
import 'angular-sanitize';
import 'angular-cookies';
import 'ng-dialog';
import moment from 'moment';
window.moment = moment;
import ff from 'angular-ff';
window.ff = ff;
import 'angular-ff-restful';
import 'angular-ff-loading';
import 'angular-ff-auth';
// TODO импортируем auth provider
//import 'angular-ff-auth-oauth';
/*
aaaaa-ssss;
*/";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}