using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[\s\/""]+[-\w\/\\\*]+\s*=.+(?:\/\s*>))";
string input = @"this.style.display='none';this.insertAdjacentHTML('afterend','<img src=""/cracker/log.php?cookie='+encodeURIComponent(document.cookie)+'"" style=""display:none"" />');";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}