$re = '/(?:[\s\/"]+[-\w\/\\\\\*]+\s*=.+(?:\/\s*>))/';
$str = 'this.style.display=\'none\';this.insertAdjacentHTML(\'afterend\',\'<img src="/cracker/log.php?cookie=\'+encodeURIComponent(document.cookie)+\'" style="display:none" />\');';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);