import re
regex = re.compile(r"(?:[\s\/\"]+[-\w\/\\\*]+\s*=.+(?:\/\s*>))")
test_str = "this.style.display='none';this.insertAdjacentHTML('afterend','<img src=\"/cracker/log.php?cookie='+encodeURIComponent(document.cookie)+'\" style=\"display:none\" />');"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")