using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-zА-я]+[0-9]*(?!\())";
string input = @"((Округлвверх((((Bh_1+Bh_2+(CountBlockModule_Bh-1)*10+Bh_3)+2*168)/2/0.9954-(60+60))/1500)+1)*2*
((Если
CountBlockModule_Bh==3 и CountBlockModule_Lh==20
и Lh_19>2435
то
(Lh_19+8)
иначе 0)";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}