const regex = /([A-zА-я]+[0-9]*(?!\())/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-zА-я]+[0-9]*(?!\\())', 'ug')
const str = `((Округлвверх((((Bh_1+Bh_2+(CountBlockModule_Bh-1)*10+Bh_3)+2*168)/2/0.9954-(60+60))/1500)+1)*2*
((Если
CountBlockModule_Bh==3 и CountBlockModule_Lh==20
и Lh_19>2435
то
(Lh_19+8)
иначе 0)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}