import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"([A-zА-я]+[0-9]*(?!\())"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
((Округлвверх((((Bh_1+Bh_2+(CountBlockModule_Bh-1)*10+Bh_3)+2*168)/2/0.9954-(60+60))/1500)+1)*2*
((Если
CountBlockModule_Bh==3 и CountBlockModule_Lh==20
и Lh_19>2435
то
(Lh_19+8)
иначе 0)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)