$re = '/([A-zА-я]+[0-9]*(?!\())/u';
$str = '((Округлвверх((((Bh_1+Bh_2+(CountBlockModule_Bh-1)*10+Bh_3)+2*168)/2/0.9954-(60+60))/1500)+1)*2*
((Если
CountBlockModule_Bh==3 и CountBlockModule_Lh==20
и Lh_19>2435
то
(Lh_19+8)
иначе 0)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);