use strict;
my $str = '((Округлвверх((((Bh_1+Bh_2+(CountBlockModule_Bh-1)*10+Bh_3)+2*168)/2/0.9954-(60+60))/1500)+1)*2*
((Если
CountBlockModule_Bh==3 и CountBlockModule_Lh==20
и Lh_19>2435
то
(Lh_19+8)
иначе 0)';
my $regex = qr/([A-zА-я]+[0-9]*(?!\())/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}