# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?)\|(ZW0=[0-9]+?0)0+(\|.*)$/$1$2$3/;t' <<< "2,5kg"