$re = '/^(.*?)\|(ZW0=[0-9]+?0)0+(\|.*)$/';
$str = '2,5kg';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;