// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(.*?)\|(ZW0=[0-9]+?0)0+(\|.*)$").unwrap();
let string = "2,5kg";
let substitution = "$1$2$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}