use strict;
my $str = '2,5kg';
my $regex = qr/^(.*?)\|(ZW0=[0-9]+?0)0+(\|.*)$/p;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";