const regex = /^(.*?)\|(ZW0=[0-9]+?0)0+(\|.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)\\|(ZW0=[0-9]+?0)0+(\\|.*)$', '')
const str = `2,5kg`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);