#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(.*?)\|(ZW0=[0-9]+?0)0+(\|.*)$"
Local $sString = "2,5kg"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)