# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^:]+://gm;t' <<< "d016eb66c977d646642d491ae8461134:12345asdf
90ef258293ee214d1128abecd7b96f99:61231afad"