#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^:]+:"
Local $sString = "d016eb66c977d646642d491ae8461134:12345asdf" & @CRLF & _
"90ef258293ee214d1128abecd7b96f99:61231afad"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)