const regex = /^[^:]+:/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^:]+:', 'gm')
const str = `d016eb66c977d646642d491ae8461134:12345asdf
90ef258293ee214d1128abecd7b96f99:61231afad`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);