re = /^[^:]+:/m
str = 'd016eb66c977d646642d491ae8461134:12345asdf
90ef258293ee214d1128abecd7b96f99:61231afad'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result