const regex = /\S*\d+\S*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S*\\d+\\S*', 'gm')
const str = `אני קניתי ב2.5~ ש"ח`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);