import re
regex = re.compile(r"\S*\d+\S*", flags=re.MULTILINE)
test_str = "אני קניתי ב2.5~ ש\"ח"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)