use strict;
my $str = 'אני קניתי ב2.5~ ש"ח';
my $regex = qr/\S*\d+\S*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";