#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\t\s\n]*\/{2,3}@?.*|export|enum(\s?\{)(\n|.)*?\}|import\s(type\s)?\{.*}\s.*;|\slang="ts"|(?<=[\w]?)(?:\:\s.[a-zA-Z\[\]\'\s\.<>]*?)(?=\s|\,)|\<.+\>(?=[\w\(\)])"
Local $sString = "import type { WorkerThread, Thread, ThreadError, WorkerThreadFn } from "models";" & @CRLF & _
"" & @CRLF & _
"export enum {" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"const pool: WeakMap<object, Thread> = new WeakMap();" & @CRLF & _
"const spawn: WorkerThread['spawn'] = (func: nice, wow, ) => {" & @CRLF & _
" const ctx = {};" & @CRLF & _
" let executor" & @CRLF & _
"}" & @CRLF & _
"if (wow <= wow > )" & @CRLF & _
"" & @CRLF & _
"export function thread<T>(): WorkerThread<T> {" & @CRLF & _
" return {" & @CRLF & _
" spawn" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"<Wiw>wow" & @CRLF & _
"thread().spawn((args) => {" & @CRLF & _
" " & @CRLF & _
"})" & @CRLF & _
"" & @CRLF & _
": Wow"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")