$re = '/[\t\s\n]*\/{2,3}@?.*|export|enum(\s?\{)(\n|.)*?\}|import\s(type\s)?\{.*}\s.*;|\slang="ts"|(?<=[\w]?)(?:\:\s.[a-zA-Z\[\]\'\s\.<>]*?)(?=\s|\,)|\<.+\>(?=[\w\(\)])/m';
$str = 'import type { WorkerThread, Thread, ThreadError, WorkerThreadFn } from "models";
export enum {
}
const pool: WeakMap<object, Thread> = new WeakMap();
const spawn: WorkerThread[\'spawn\'] = (func: nice, wow, ) => {
const ctx = {};
let executor
}
if (wow <= wow > )
export function thread<T>(): WorkerThread<T> {
return {
spawn
}
}
<Wiw>wow
thread().spawn((args) => {
})
: Wow';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);