import re
regex = re.compile(r"[\t\s\n]*\/{2,3}@?.*|export|enum(\s?\{)(\n|.)*?\}|import\s(type\s)?\{.*}\s.*;|\slang=\"ts\"|(?<=[\w]?)(?:\:\s.[a-zA-Z\[\]\'\s\.<>]*?)(?=\s|\,)|\<.+\>(?=[\w\(\)])", flags=re.MULTILINE)
test_str = ("import type { WorkerThread, Thread, ThreadError, WorkerThreadFn } from \"models\";\n\n"
"export enum {\n\n"
"}\n\n"
"const pool: WeakMap<object, Thread> = new WeakMap();\n"
"const spawn: WorkerThread['spawn'] = (func: nice, wow, ) => {\n"
" const ctx = {};\n"
" let executor\n"
"}\n"
"if (wow <= wow > )\n\n"
"export function thread<T>(): WorkerThread<T> {\n"
" return {\n"
" spawn\n"
" }\n"
"}\n"
"<Wiw>wow\n"
"thread().spawn((args) => {\n"
" \n"
"})\n\n"
": Wow")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")