use strict;
my $str = 'import type { WorkerThread, Thread, ThreadError, WorkerThreadFn } from "models";
export enum {
}
const pool: WeakMap<object, Thread> = new WeakMap();
const spawn: WorkerThread[\'spawn\'] = (func: nice, wow, ) => {
const ctx = {};
let executor
}
if (wow <= wow > )
export function thread<T>(): WorkerThread<T> {
return {
spawn
}
}
<Wiw>wow
thread().spawn((args) => {
})
: Wow';
my $regex = qr/[\t\s\n]*\/{2,3}@?.*|export|enum(\s?\{)(\n|.)*?\}|import\s(type\s)?\{.*}\s.*;|\slang="ts"|(?<=[\w]?)(?:\:\s.[a-zA-Z\[\]\'\s\.<>]*?)(?=\s|\,)|\<.+\>(?=[\w\(\)])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}