const regex = /[\t\s\n]*\/{2,3}@?.*|export|enum(\s?\{)(\n|.)*?\}|import\s(type\s)?\{.*}\s.*;|\slang="ts"|(?<=[\w]?)(?:\:\s.[a-zA-Z\[\]\'\s\.<>]*?)(?=\s|\,)|\<.+\>(?=[\w\(\)])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\t\\s\\n]*\\\/{2,3}@?.*|export|enum(\\s?\\{)(\\n|.)*?\\}|import\\s(type\\s)?\\{.*}\\s.*;|\\slang="ts"|(?<=[\\w]?)(?:\\:\\s.[a-zA-Z\\[\\]\\\'\\s\\.<>]*?)(?=\\s|\\,)|\\<.+\\>(?=[\\w\\(\\)])', 'gm')
const str = `import type { WorkerThread, Thread, ThreadError, WorkerThreadFn } from "models";
export enum {
}
const pool: WeakMap<object, Thread> = new WeakMap();
const spawn: WorkerThread['spawn'] = (func: nice, wow, ) => {
const ctx = {};
let executor
}
if (wow <= wow > )
export function thread<T>(): WorkerThread<T> {
return {
spawn
}
}
<Wiw>wow
thread().spawn((args) => {
})
: Wow`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}