using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\t\s\n]*\/{2,3}@?.*|export|enum(\s?\{)(\n|.)*?\}|import\s(type\s)?\{.*}\s.*;|\slang=""ts""|(?<=[\w]?)(?:\:\s.[a-zA-Z\[\]\'\s\.<>]*?)(?=\s|\,)|\<.+\>(?=[\w\(\)])";
string input = @"import type { WorkerThread, Thread, ThreadError, WorkerThreadFn } from ""models"";
export enum {
}
const pool: WeakMap<object, Thread> = new WeakMap();
const spawn: WorkerThread['spawn'] = (func: nice, wow, ) => {
const ctx = {};
let executor
}
if (wow <= wow > )
export function thread<T>(): WorkerThread<T> {
return {
spawn
}
}
<Wiw>wow
thread().spawn((args) => {
})
: Wow";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}