#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<prefix1>\d{0,3}?)(?<suffix1>\d{1,3})\/(?<prefix2>\d{0,3}?)(?<suffix2>\d{1,3})\/"
Local $sString = "1/1/" & @CRLF & _
"12/1/" & @CRLF & _
"123/1/" & @CRLF & _
"1234/1/" & @CRLF & _
"12345/1/" & @CRLF & _
"123456/1/" & @CRLF & _
"" & @CRLF & _
"1/12/" & @CRLF & _
"1/123/" & @CRLF & _
"1/1234/" & @CRLF & _
"1/12345/" & @CRLF & _
"1/123456/" & @CRLF & _
"" & @CRLF & _
"12/12/" & @CRLF & _
"123/12/" & @CRLF & _
"1234/12/" & @CRLF & _
"12345/12/" & @CRLF & _
"123456/12/" & @CRLF & _
"" & @CRLF & _
"12/123/" & @CRLF & _
"12/1234/" & @CRLF & _
"12/12345/" & @CRLF & _
"12/123456/" & @CRLF & _
"" & @CRLF & _
"123/123/" & @CRLF & _
"1234/123/" & @CRLF & _
"12345/123/" & @CRLF & _
"123456/123/" & @CRLF & _
"" & @CRLF & _
"123/1234/" & @CRLF & _
"123/12345/" & @CRLF & _
"123/123456/" & @CRLF & _
"" & @CRLF & _
"1234/1234/" & @CRLF & _
"12345/1234/" & @CRLF & _
"123456/1234/" & @CRLF & _
"" & @CRLF & _
"1234/12345/" & @CRLF & _
"1234/123456/" & @CRLF & _
"" & @CRLF & _
"12345/12345/" & @CRLF & _
"123456/12345/" & @CRLF & _
"" & @CRLF & _
"12345/123456/" & @CRLF & _
"" & @CRLF & _
"123456/123456/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")