// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<prefix1>\d{0,3}?)(?<suffix1>\d{1,3})\/(?<prefix2>\d{0,3}?)(?<suffix2>\d{1,3})\/").unwrap();
let string = "1/1/
12/1/
123/1/
1234/1/
12345/1/
123456/1/
1/12/
1/123/
1/1234/
1/12345/
1/123456/
12/12/
123/12/
1234/12/
12345/12/
123456/12/
12/123/
12/1234/
12/12345/
12/123456/
123/123/
1234/123/
12345/123/
123456/123/
123/1234/
123/12345/
123/123456/
1234/1234/
12345/1234/
123456/1234/
1234/12345/
1234/123456/
12345/12345/
123456/12345/
12345/123456/
123456/123456/
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}